This forum is new. Don't be shy, get posting
and let's build a great community together.

  • Zeej

    What is the correct workflow for working with a Maya connection where the Maya scene world coordinate system is set to Z-up?

    When I create a hook/connection the orientation of the HDRLS skydome is incorrect. (i.e. the default gradient background runs left/right instead of up/down)
    I'm used to this as the same thing occurs when a skydome is created using the Arnold lights menu in Maya. Usually I'll simply reorient the skydome sphere and continue.

    I've tried doing this fix when using the Maya/HDRLS connection, and the gradient background displays correctly, but then when using the light paint tool the positioning of the lights is miscalculated resulting in misplaced lights.

    If I keep the skydome on it's incorrect orientation the light paint tool works correctly but there's no way to use background gradients because the poles of the skydome sphere are left/right rather than up/down which creates a hard seam where the start and end of the gradient values meet.

    I'm rendering with Arnold using the framebuffer. I've tried exporting the scene data using HDRLS render view (which I don't want to do as I need to render using Arnold materials) and couldn't get any of the export formats to be recognised as using Z-up, nor could I change it as the option was not selectable.

    Have I missed a setting somewhere? Any help greatly appreciated.

  • Zeej
    Solved my problem after watching a lot of the support videos (very useful, especially the combined one, but didn't glean anything about my problem) and looking through various help pages - I eventually came across a page about legacy workflows for Maxwell, which isn't something I use but there was a big clue in there.

    I'll put it simply in case anyone else encounters the problem I was having.

    The mistake I was making was that I was loading a scene in Maya then hitting the HDRLS start connection button on the shelf, which automatically creates the skydome and initialises the connection. This isn't the way to do it.

    The solution for me was the following steps:

    • create a skydome manually (rename it although not necessary for this to work)
    • make the rotation adjustment (.rx=90)
    • connect a Maya file node outColour output to the skydomeShape node color input
    • assign a (random) .exr file in the file node
    • then hit the connection button

    The hook modal window identifies the skydome and names the hook after the shape name.

    Hit the OK button and it all works as expected :party:
  • Forum Admin
    We are very grateful for you sharing your solution here.

    I know that for automotive work, there are customers using the none default Z up, and not Y up in Maya.

    We always assumed the default Y up workflow.

    I am glad you have found a workaround that works for you, again thanks for sharing.
  • Zeej
    More than happy to contribute! :)
Add a Comment

New Member Reminder
Make sure you have activated your account via the email we sent you. That grants you permission to post at the forum.

New for December 2020

Welcome to our new HDR Light Studio forum. Please create an account to start or join a discussion.